Uncategorized

Dr. Tuxwarrior: Será lo mismo?

Aqui Dr. Tuxwarrior leyendo los mail de nuestros lectores:

“Dr. Tuxwarrior he tenido una duda que me ha mantenido inquieto durante mucho tiempo y ya no se que hacer, la pregunta es: ¿Es lo mismo baño que servicio?”

eeee
(sonido de palma de la mano impactando de talegazo en una frente)
Si claro por esa razon ire a un ISP y dire: “quiero contratar un baño de internet”, En fin es lo mismo no?

[Chiste solamente disponible o entendible en El Salvador en caso de que sea chiste]

Anuncios
Estándar
/me, informatica, laptop, planet, Uncategorized

Programas de 32 bits no disponibles en AMD64

Todos los que hemos hecho el salto a 64 bits en linux nos encontramos con este problema (el mas grande de todos diría yo), estamos acostumbrados a conseguir todo (o casi todo) nuestro software de los repositorios e incluso algunos programas no-libres que estamos a veces obligados a conseguir por culpa de los amigos que tenemos o la empresa en la que laboramos que lo #exige, o incluso los que nos gusta jugar con consolas que ya no estan vigentes (emulacion) a veces no encontramos disponible el emulador al que estamos acostumbrados, aqui pongo una guía para instalar 2 aplicaciones no disponibles para AMD64 en debian:

1-ZSNES: Este es para mi el mejor emulador de SNES existente, no solo es potente, rápido y muy similar a lo que era la propia consola, ademas de todo es libre, el problema es que por alguna razon que no conozco no es posible compilarlo para 64 bits (si lo intente y varias veces), por lo que no existe un deb para AMD64, lo que hice para hacerlo funcionar fue lo siguiente:

* Bajar la version de 32 bits de packages.debian.org, les recomiendo que bajen la versión disponible para su rama de distro (stable, testing o unstable), y lo instalan de esta manera:

dpkg -i --force-architecture zsnes_****_i386.deb

Cambien la censura de asteriscos por la version que bajaron, luego bajen la única dependencia (que yo necesité) que necesita en 32 bits para funcionar, igual que con el emulador bajen la version de 32 bits de libao2, pero en lugar de instalarla con dpkg (por que puede reemplazar la version para 64 bits creando un error enorme en el sistema) la descomprimimos con (ark en KDE, fileroller en Gnome, Xarchiver en XFCE y LXDE):

ar -x libao***i386.deb

Y luego descomprimir el archivo “data” dentro de la resultante:

tar -xvf data.tar.gz 

entramos a usr/lib (dentro de la carpeta data, no en el sistema) y copiamos todo el contenido hacia /usr/lib32/ (esto si en el sistema):

cp -r * /usr/lib32/

ADVERTENCIA: no lo copien a /usr/lib o /usr/lib64, eso hara ESTRAGOS en el sistema.

Una vez listo damos en la consola el comando:

zsnes

Y veremos la pantalla del emulador listo para jugar \o/.

2- skype

Este es EVIL, por obligacion (unos primos en el norte que no conocen linux) tengo que usar este ya que es la unica forma de hacer una videoconferencia decente con gente que odia el mazinger, bueno para instalar este adefesio en AMD64 es necesaria una enorme cantidad de dependencias, skype lo instalamos igual como zsnes (solo que ese lo bajan de la página de la empresa skype no de debian), y lo instalan asi:

dpkg -i --force-architecture skype******.deb

Las dependencias son las siguientes, (bajar todas de packages.debian.org):

-libqt4-dbus
-libqt4-network
-libqtqui4
-libqtcore4
-libqt4-xml

Hagan el proceso que describí anteriormente para libao y skype funcionara en AMD64

Estándar
Uncategorized

Instalar los escritorios grandes sin la basura

Si eres un usuario GNU/linux desde hace algun tiempo te habras dado cuenta que algunos (en ocasiones muchos) programas que se instalaron automáticamente con tu distribución no los utilizas o se abren en lugar de los que tu prefieres por ser los “default” del entorno (ej: noatun en kde, totem en gnome), pero el mayor problema lo constituye el intentar desinstalar solo el (o los) programa(s) que nos hace estorbo o tenemos de adorno se va todo el escritorio y sus dependencias, como arreglar eso?

Pues la solución es instalar solamente el “CORE” del entorno de escritorio, la forma debian (y ubuntu) sería de esta manera:

apt-get install gnome-core

en caso de gnome

apt-get install kde-core

en caso de kde 3

apt-get install kde-minimal

en caso de kde 4

Espero que les sea de ayuda, pueden despedirse de los estorboware :p

Estándar